
Intensity Corre lat ion Ana lysis 
This plugin generates Mander’s coefficients as well as performing Intensity Correlation Analysis as 
described by Li et al.  To fully understand this analysis you should read: 
Li, Qi, Lau, Anthony, Morris, Terence J., Guo, Lin, Fordyce, Christopher B., and Stanley, Elise F. (2004). 
A Syntaxin 1, G{alpha}o, and N-Type Calcium Channel Complex at a Presynaptic Nerve Terminal: 
Analysis by Quantitative Immunocolocalization. Journal of Neuroscience 24, 4070-4081. 
Manders, EEM, Verbeek, FJ., and Aten, JA. (1993). Measurement of co-localisation of objects in dual-
colour confocal images. Journal of Microscopy 169, 375-382. 

1. Open your two images (File/Open).  

2. You must background subtract each stack: 
 2a. Select a BG ROI. 
 2b. Run Plugins/ROI/BG subtract from ROI. 
 2c. Set threshold if required. 

3. Run the ICA plugin (Plugins/Colocalization Analy sis/Image 
Correlation Analysis) 

 

Channel Combination 
Select the combination of channel colour, e.g. a TRITC vs FITC analysis would be Red:Green; a FITC vs 
DAPI would be Green: Blue. This determines the colouring given to the ICA plots and the merged image. 

Use ROI 
Choose a ROI to analyse from the drop down box. Choose either ‘none’ to anlyse the 
whole image or “Channel 1:’ to analyse the pixels in both channels within the ROI 
selected in channel 1. 

Use Thresholds 
If this is selected, pixels below the image’s threshold will not be included in the analysis. For 
instructions on how to set the threshold, see:  
http://rsb.info.nih.gov/ij/docs/menus/image.html#adjust and 
http://www.uhnresearch.ca/facilities/wcif/imagej/particle_analysis.htm#threshold 

Keep merged ROI 
Returns a merged image of the analysed ROI (or full image). The merged colours are determined 
by the “Channel combination” selected. 

http://rsb.info.nih.gov/ij/docs/menus/image.html#adjust
http://www.uhnresearch.ca/facilities/wcif/imagej/particle_analysis.htm#threshold


 

Display Colour Scatter plot 
This generates a scatter-plot of red intensities vs green intensities. The colour of the scatter plot pixel 
represents the actual colour in the image. This does not tell you the frequency of the pixel, but is easier to 
relate to the original image. 

Display Frequency Scatter plot 
The pixels in this scatter-plot pseudocoloured so that their colour represents the frequency of the red-green 
pixel combination in the original image (hot colours representing high values by convention). This 
sort of plot contains the most information, but can be a little difficult to relate it back to the 
original image. 

Display intensity counts  
This generates a text window with the red intensities, green 
intensities and frequency of the intensity pairs. This can be 
exported to a spreadsheet program for further analysis. 

Current Slice Only 
Select this if you do not wish to analyse the whole stack. Only the current slice in the Channel 1 stack (and 
the corresponding slice in the green channel) will be analysed. 

Display ICA plots 
When checked this option draws two plots, one for the red channel one for the green. The axes on the plots 
are the PDM values on the x-axis and the red or green intensity on the y-axis.  

The PDM value is the Product of the Differences from the Mean, i.e. for each pixel: 
PDM = (red intensity- mean red intensity)×(green in tensity – mean green intensity) 1 

 

Crosshair size (pixels) 
The points of the ICA plots are plotted as cross-hairs. You can select the size of 
the crosshair here. 

Display PDM image 
This option generates a new image where each pixel is equal to the PDM value at 
that location. The Image is pseudocoloured and a PDM scale bar is inserted.  

For clarity, pixels that are below average in both channels are excluded.  

Display +ves only 
This option will generate a 2 slice stack. The first images pixels are the positive PDM 
values resulting from both pixels above the mean (i.e. red intensity-mean red intensity 
and green intensity-mean green intensity are both positive). The second slice are pixels 
that have pixel values in each channel which are both below the mean (i.e. red 
intensity-mean red intensity and green intensity-mean green intensity are both 
negative). 

                                                        
1 PDM is equal to the value (A-a)*(B-b) as described in Li et al. 2004. 



 

List PDM values 
This generates a list of PDM values that can be exported to spreadsheet programs for further analysis.  

 

 

Results Window 

 

If the Results window is closed or does not contain ICA data then the plugin will enter a “Header” row then 
the data row. The second time the plugin is run only the data row is entered. The column information is 
detailed below. 

Image 
The name of the images and the ROI that has been analysed is entered in the Image column. If no ROI was 
selected of the “Use ROI” option unchecked then the ROI describes the image dimensions. 

Rr  
This is the Pearson’s correlation coefficient. Zero-zero pixels are not included in this calculation. 

This is a popular method of quantifying correlation in many fields of research from psychology to 
economics. In many forms of correlation analysis the values for Pearson’s will range from 1 to -1. A value 
of 1 represents perfect correlation; -1 represents perfect exclusion and zero represents random localisation. 
However, this is not the case for images. While perfect correlation gives a value of 1, perfect exclusion 
does not give a value of -1. Low (close to zero) and negative values for Pearson’s correlation coefficient for 
fluorescent images can be difficult to interpret. However, a value close to 1 does indicate reliable 
colocalisation.  

R 
This is Mander’s Overlap coefficient. This is easier than the Pearson’s coefficient to comprehend. It ranges 
between 1 and zero with 1 being high-colocalisation, zero being low. However, the number of objects in 
both channel of the image has to be more or less equal. 

Ch1:Ch2 
This value represents the red: green pixel ratio. The Overlap coefficient (R) is strongly influenced by the 
ratio of red to green pixels and should only be used if you have roughly equal numbers of red and green 
pixels (i.e. Nred ÷ Ngreen pixels ~1). 

M1 and M2 
These split coefficients are Mander’s Colocalization coefficients for channel 1 (M1) and channel 2 (M2). 

These split-coefficients avoid issues relating to absolute intensities of the signal, since they are normalised 
against total pixel intensity. We also get information as to how well each channel overlaps the other. There 
are cases where red may overlap significantly with green, but most of the may not overlap with the red. 



 

If the assumption is made that greyscale number equates to dye molecules (this is not necessarily correct) 
then these coefficients represent the percentage of red dye molecules that share their location with a green 
dye molecule. 

These coefficients are very sensitive to poor background correction and do not take in to account the 
intensity of the second channel, other than it is non-zero. For example, a bright red pixel colocalising with a 
faint green pixel is considered equivalent to a bright red pixel colocalising with a bright green pixel. 
Intuitively, a red-green pixel-pair of similar intensities should be considered “more colocalised” than a 
pixel pair of widely differing intensities. 

N+ve 
This represents the number of pixel pairs that have a positive PDM value. 

Ntotal 
This is the number of pixels pairs in the images that where at least one of the pixel pairs is above zero.. 

ICQ 
This is the Intensity Correlation Quotient. If the intensities in two images vary in synchrony (i.e. they are 
dependent), they will vary around their respective mean image intensities together. So, if a pixel’s intensity 
is below average in the red channel (i.e. Ri-Rmean< 0); it will be below average in the green channel (i.e. Gi-
Gmean<0). Similarly, if a pixel is above average in one channel it will be above average in the other. 
Therefore, in an image where the intensities vary together, the product of the differences from the mean 
(PDM), will be positive. The converse is true. If the pixel intensities vary asynchronously, i.e. the channels 
are segregated so that when a red pixel is above average, the corresponding green pixel is below average; 
then most of the PDMs will be negative. 

The ICQ is based on the non-parametric sign-test analysis of the PDM values and is equal to the ratio of the 
number of positive PDM values to the total number of pixel values. The ICQ values are distributed between 
-0.5 and +0.5 by subtracting 0.5 from this ratio. 

Random staining: ICQ~0; Segregated staining: 0> ICQ≥ -0.5; Dependent staining: 0<ICQ≤+0.5 



 

 

Instruct ions for the ImageJ-based ICA ICQ analysis module. 

Installation 
Download the ImageJ bundle from the TWRI Wright Cellular Imaging Facility web site. 
[www.uhnresearch.ca/wcif] 

Open Images 
1. Review deconvolved image stack or confocal image and select 2-3 planes with clear staining. 

2. For each plane save three images in TIFF format: the colour merge and single of each stain alone 
(16bit) for ICA analysis (the colour overlay can be created from single channel images in ImageJ 
after transfer: Image>Color>RGB merge) 

Subtract Background (BG) 
For each image: 

1. Convert to 8 bit (Image>type>8bit) 

2. Adjust Brightness/Contrast (Use the rectangle tool to select the region of interest.  Open the tool 
box: ‘Image>Adjust>Brightness/Contrast’.  Click on ‘auto’).  Note: this does not affect the values of 
the pixels unless you press the “Apply” button) 

3. Subtract background staining (Use the rectangle tool to select a region in a blank area of the slide.  
Plugins>ROI>BG subtraction from ROI, accept default ‘3’. 

4. Enlarge the area of interest (Magnifying lens button; click on the centre of the area to be enlarged.  
The image window size can be adjusted by selecting the rim and dragging)  

Select region of interest (ROI) 
If the analysis is for the whole image and not a subregion skip this step for both image pairs. 

1.  Use one of the shape select tools (the left hand end of buttons: rectangle, oval, polygon or freehand 
– I find the latter the most useful for a specific cell area) to demarcate the analysis area.  The tool 
will automatically close off the shape when the mouse button is released. 

2. Save this (File>SaveAs>selection). Freehand selections can be edited by first converting it to a poly-
line with the menu command Edit>Selection>Fit spline and then by dragging the nodes. 

3. For the Other image Open the area shape created for the first image (File>open>****.roi; where *** 
depends on the shape type (rectangle, oval etc.). The ROI can also be restored with the menu 
command Edit>Selection>Restore Selection (keyboard shift-E). 

Set threshold 
1. Select the channel 1 image window by clicking on the title bar. 

2. Open the threshold box (Image>Adjust>Threshold). The Threshold box will depict a frequency 
histogram of the staining intensities. 

3. Adjust the lower threshold to the onset of the histogram.  This can be used to cut off background 
staining – but only with caution since this is a value judgment.  My experience is that the threshold 
should be set to either the base of the histogram or the lowest value.  Depending on your camera 
settings/image brightness, this can be displaced almost to extinction to the left.  Regardless, in all 
cases the minimum threshold must be >0.  Set the upper threshold to the maximum value (255).  
Click on ‘Set’ and accept.  

4. Select the channel 2 image window by clicking on the title bar and set the Threshold for this ROI. 

Perform ICA 
1. Select Image Correlation Analysis (Plugins>Colocalisation Analysis>Image Correlation Analysis) 

2. Ensure that the correct two files are listed in Channel 1 and Channel 2. 



 

3. Select “Channel 1” from the “Use ROI” drop down box. 

4. Select the colour combination of your original overlay (this is just to keep things consistent) 

5. Make selections of which functions you would like to use.  In any case, select “Display Frequency” 
“Scatter Plot” and “Display ICA plots”.  The PDM image is useful to identify subregions of 
correlated and separated staining.  I also recommend selecting the PDM values.  This generates a 
worksheet of the pixel intensity pairs that can be used in a spreadsheet at a later date.   

6. Click on OK. 

A number of windows will open with graphs, images or spreadsheets (the number depends on the boxes 
checked in the previous screen).  The Results spreadsheet window summarizes the conditions, lists the 
number of positive and negative PDM values and also calculates the ICQ.  

Save 
In order to keep the results of the analysis first save the Results and PDM values files from within and then 
close their windows.  The remaining windows can all be saved as TIFF files in a single step as follows. 
SaveAs>SaveAllAsTiff which opens a selection box. 

This method is recommended since attempting to save the original images one at a time will actually 
superimposing the modified files (e.g. 16 bit to 8 bit conversion; background subtraction) on the original 
raw data. 

Interpretation. 
Please see Li et al for details.  However, we recommend statistical analysis of ICQ values based on 
multiple cells, each generating a single value.  This is least likely to generate spurious analyses.  

 


